Inicio > Debian, Linux > El instalador de Debian Squeeze no configura en el Grub la entrada para windows Vista

El instalador de Debian Squeeze no configura en el Grub la entrada para windows Vista

Hola,

estos días estoy migrando un PC a Windows Vista y Debian GNU/Linux  Squeeze amd64. Después de instalar Vista procedí a la instalación de Debian. Antes de acabar la instalación de Debian y al configurar el gestor de arranque Grub, el instalador detectó que vista estaba instalado y avisó de que procedía a configurar el arranque. Pero al reiniciar tras la instalación me encontré con que en las entradas del Grub no aparecía la referente a Vista, solo las de Debian.

Inicie sesión como root y comprobé en el fichero de configuración de Grub en /boot/grub/grub.cfg que efectivamente no aparecía la entrada correspondiente a Vista. Parece un bug del instalador que aunque detecta otros SO no puede configurar el arranque correctamente.

Procedí a ejecutar en una consola el comando update-grub2 que detecto la partición de Vista y procedio a añadir las entradas corresondientes en el grub.cfg.

Reinicie el equipo y ahora aparece correctamente la entrada correspondiente a Vista que cargó sin problemas al seleccionarlo.


Todo apunta a un bug del instalador de Squeeze aunquee no debemos olvidar que es una versión testing.

Por cierto, los tiempos de arranque entre Debian Squeeze amd64 con ext4 como sistema de ficheros son  inferiores a Debian Lenny i386 con ext3 como sistema de ficheros. Me ha sorprendido gratamente. El equipo usado es el mismo, solo cambia el disco duro (ambos de 7200 rpm)

Anuncios
Categorías:Debian, Linux
  1. Gabriel Herz
    Lunes, 11 marzo 2013 en 5:10 am

    Y aún después de mucho tiempo la configuración de grub no cambia, sigue igual, el win7 no me lo detecta, el squeeze y el ubuntu y todos los demás tienen el mismo problema porque implementan el mismo Grub y Lilo, debería de haber una forma menos engorrosa, grub debería utilizar las librerías de este grub2 (no sé si será un fork). No me gusta linux por esto, no arregla muchas cosas que debería de solucionar, años y años con el mismo rollo.

  2. Samuel
    Viernes, 27 enero 2012 en 8:54 pm

    Hola a todos:
    Muy buen tutorial. Tengo un problema con mi grub tengo instalado Sqeeze 64 y Windows XP y cuando entro por Windos al reiniciar la pc se pierder el grub. Lo recupero entro y salgo por linux y sin problemas pero cuando entro a windows se fastidia de nuevo el GRUB.

    Muchas Garcias de antemano

  3. Oscar
    Jueves, 27 mayo 2010 en 6:11 pm

    Hola,
    muy bueno el tutorial, felicitaciones.
    Tu crees que esta solución servirá para utilizar dos SO Linux?
    Me explico, yo uso normalmente para producción Lenny, pero me gustaría instalar Squeeze para trastear. Bienvenida cualquier sugerencia.

    Saludos.

    • tolgalen
      Jueves, 27 mayo 2010 en 6:53 pm

      No sé si el error es solo con el Vista o se da tambien en otros casos.

      Si quieres trastear lo mejor es que la instales en una máquina virtual (virtual box, vmware player)

      El 27/05/2010 18:11,

      • roberto
        Viernes, 4 junio 2010 en 2:34 am

        hola

        Muchas gracias por la ayuda, a mi tampoco me detectó windows xp en la primera partición y con el update-grub2 lo solucioné.

        saludos

      • Oscar
        Viernes, 4 junio 2010 en 4:44 pm

        Gracias tolgalen por tu sugerencia, pero no me gusta usar máquinas virtuales, decidí instalarlo y apliqué tu tutorial, funcionó correctamente, otra cosa en el panel de Squeeze network manager aparece desconectado aun funcionando internet, en este link http://josegjimenez.wordpress.com/2010/02/19/networkmanager-en-canaima-aparece-desconectado-aun-teniendo-internet-solucion/ está la solución y funciona correctamente, espero que a alguno de los seguidores de tu blog le sea útil.
        Espero me disculpes el atrevimiento de dar sugerencias en tu página.
        Saludos.

        • tolgalen
          Viernes, 4 junio 2010 en 5:01 pm

          Hola,

          yo las pruebas las prefiero hacer sobre máquinas virtuales, es mucho más flexible, y no solo pruebas, tengo algún server que es una máquina virtual.

          No me molesta la suguerencia, al contrario.

          El 04/06/10 16:44,

  1. Martes, 8 febrero 2011 en 2:07 pm

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: